حل مشکل php-mongodb _clock_gettime

اگر قصد ارتباط بین php و mongodb روی پلتفورم مک و ال کپیتان داشته باشید، نیاز به php mongo-db دارید و اگر هم از brew برای اون استفاده کنید ، ممکن هست به ارور زیر بخورید:

 

تو این شرایط اول xcode-select رو از اپ استور به آخرین ورژن اپگرید کنید. اگر هم ندارید با دستور زیر نصب کنیدو بعد آپگرید کنید:

 

تو قدم بعدی باید پکیج نصب رو ادیت کنید. با توجه به اینکه چه پکیجی رو انتخاب کردید ،‌مثلا php56-mongodb باید همون پکیج ادیت شه.

و دستور شرطی زیر رو توی قسمت install بزارید:
مثلا یه همچین چیزی:

 

توجه داشته باشید که ادیتور پیش فرض brew ،ادیتور vim هست واگر بلد نیستید باهاش کار کنید این دو تا دستور بدردتون می خوره:

 

قدم اخر هم نصب مجدد با استفاده از تغییراتی که الان دادید هست:

 

موفق و پیروز باشید